maddhin

Offline Folders: loading extremely slow

Recommended Posts

Hi,

when I open an offline folder to read it, it takes 30 seconds but often 1-3 minutes(!) until the content is presented. That is really annoying and doesn't seem to be related as to whether the mobile is connected to the internet or not. After all this time, it also seems that not even all 100 articles are loaded but ~20 and it will load for a while again to load the next batch. Frustrating.

After clicking on the folder, it shows the moving loading wheel. Somtimes also "Downloading 0%" etc. But the "downloading" is inconsistent - sometimes it shows, sometimes not; sometimes it seems to wait until the download of new articles is finished to show the folder content, sometimes it shows the content after a waiting time and THEN adds the new articles in the middle of reading...

I first though this is a issue with the connection to the server. So I changed away from the jp. server to the normal server. No change.

Then, I went into airplane mode. No change, it still takes forever to load the pre-downloaded(!) offline folder...

Normal folders load at normal speed and do not have the lack of the offline folders.

 

I think there are still major issues with the offline folders. Besides the frustrating waiting time, there is still some weird behavior when reading an offline folder and new articles are added (weird scrolling and marking unread arcticles as read - I posted this issue a while ago and it was fixed back then but I guess got broke in a update version).

 

Could you please look into this? Many thanks in advance!

Share this post


Link to post
Share on other sites

Actually loading time highly depends of the amount of articles, their content, your device performance, etc. 

Could you please provide is the options set to you for this/these offline folder and also the database and cache size (from preferences)? 

Also what is your device model? 

Share this post


Link to post
Share on other sites

Hi Wesson,

I'm using an iPhone6 and in the offline settings everything is switched on with maximum articles at 100. Cache is 125.5 MB, database 250.5 MB.

I absolutely understand that it loads slower if images and a lot of articles are switched on, yet "none-offline folders" load generally much much much faster (almost instantly if you don't count the loading of the images) even though they need to get the data from internet first. I think, the offline folders also only load 20 articles firstly.

So, if the offline folder needs ~1 minute to load 20 articles, something seems to be stuck in the background. IMHO offline folders should load fast (at least while in airplane mode) than normal folders, or? :)

Many thanks

 

EDIT: the download of the articles for the offline folders is also very slow - which is understandable to a degree consindering the options I chose but in combination with the extremly slow loading of the folders, offline folders are only for patient people :))

Share this post


Link to post
Share on other sites

Actually we can't simulate similar behavior here with such delays in our test lab and also there is no any other similar feedback. 

We can try with something simple/trivial here in order to eliminate the possibilities of corrupted database or something related. Namely - simply reinstall the app (uninstall/and clean install) in order to completely remove the application databases and create them again. 

Let us know about the result after that. 

Share this post


Link to post
Share on other sites

Theoretically everything will be deleted (settings, orders, etc.) and you'll need to set up again. 

But I have another suggestion. Could you please go to the app settings and "Clear caches"? This will remove all articles locally saved from your offline folders but won't remove your settings.  

Share this post


Link to post
Share on other sites

Dear Wesson,

many thanks - the posting came too late... I erased and reinstalled the app. Weirdly, some of the data seem to have persistend - eg immediately after download the logo showed the unread articles and folders inside the app also but preferences seem to have been reset.

As far as I can see now, it works as advertised again and offline folders are loading almost instantly. I will continue testing and revert if the problem persists or comes back.

Thanks for your help!

Share this post


Link to post
Share on other sites

no worries - but I am sorry how much time I wasted starring at this loading wheel instead of just making a new install... Should have posted earlier... :-D

Anyway, many thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now