Graham Poole

Can't add feed - works in Feedly?

9 posts in this topic

Hey, I'm trying you guys out, and hoping to move to Inoreader fully soon. But I just ran into a problem with a feed not being able to be added.

Specifically, the feed is: http://www.webtoons.com/en/fantasy/elf-and-warrior/rss?title_no=908

I have added other feeds from the same website without issues. I can add it to Feedly without complaint.

Ran a W3C validation on it. https://validator.w3.org/feed/check.cgi?url=http%3A%2F%2Fwww.webtoons.com%2Fen%2Ffantasy%2Felf-and-warrior%2Frss%3Ftitle_no%3D908

Only difference between it and the feeds from the same site that work is the "not well-formed" error on line 15, which I take to mean that it has an ampersand in it? I would have hoped Inoreader would have a better solution that just failing, though.

Can someone tell me why this feed won't work?

Thanks.

Share this post


Link to post
Share on other sites

It is mandatory to escape ampersands in XML, because this symbol itself is used to escape other symbols. In other words, instead of having just a plain &, their code should say & to represent an ampersand.

Feedly attempts to correct this kind of problem on their side, but Inoreader follows the proper standards, which is the correct thing to do to avoid unexpected bugs and incompatibilities.

I've reported this problem to Webtoons. Please do the same.

Jacket likes this

Share this post


Link to post
Share on other sites

Yeah, I had figured that was the case. I had just hoped you guys would have a workaround for that, and would parse for &s that aren't part of symbol codes, as Feedly seems to do.

I mean, I get why you wouldn't bother, but I've seen (and in the past made) enough RSS feeds that didn't validate for various reasons that's it's a bit disappointing. We're not always able to report the issue, and the site may not always act on those reports anyways.

Regardless, I have reported it.

If you can recommend a feed-sanitizing service, I'll happily use that?

Share this post


Link to post
Share on other sites

same problem here:

trying to add the feed from:
http://www.menofstyle.gr/feed/

works fine in feedly:
https://feedly.com/i/subscription/feed/http://www.menofstyle.gr/feed/

while I can't add it in inoreader:
the url:
https://www.inoreader.com/?add_feed=http%3A%2F%2Fwww.menofstyle.gr%2Ffeed%2F

redirects to:
https://www.inoreader.com/discovery/search/http%3A%2F%2Fwww.menofstyle.gr%2Ffeed%2F

and then says no feed found!

my issue doesn't contain any special characters,
please support help

Share this post


Link to post
Share on other sites

This feed is returning "Forbidden" to our crawler. I can't even open it in my browser, so it's probably a geo block. If you have contacts of the owners, you can tell them about that. I think you know in which country our servers are.

[root@poller1 ~]# curl 'http://www.menofstyle.gr/feed/' --verbose
* Hostname was NOT found in DNS cache
*   Trying 185.4.132.8...
* Connected to www.menofstyle.gr (185.4.132.8) port 80 (#0)
> GET /feed/ HTTP/1.1
> User-Agent: curl/7.38.0
> Host: www.menofstyle.gr
> Accept: */*
>
< HTTP/1.1 403 Forbidden
* Server nginx is not blacklisted
< Server: nginx
< Date: Fri, 17 Mar 2017 18:27:43 GMT
< Content-Type: text/html; charset=iso-8859-1
< Content-Length: 274
< Connection: keep-alive
< Vary: Accept-Encoding
< Vary: Accept-Encoding
<
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>403 Forbidden</title>
</head><body>
<h1>Forbidden</h1>
<p>You don't have permission to access /feed/
on this server.</p>
<hr>
<address>Apache Server at www.menofstyle.gr Port 80</address>
</body></html>
* Connection #0 to host www.menofstyle.gr left intact

Screen Shot 2017-03-17 at 20.27.22.png

patrickdrd likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now